Resolved
The situation is resolved
Monitoring
We discovered an expired secret related to Admin tasks in identity server. This has been updated and we are back to regular operations. We'll monitor the solution for the rest of the day.
Investigating
We are investigating an issue related to onboarding/creating new users in the platform. Admins might find themselves unable to create new accounts, resulting instead in a generic error message. If you need to create an account, please reach out to support@simplifai.ai or your usual contact person.
There's no indications of issues with the identity server or the platform in general beyond this.