Resolved
The situation is resolved
Monitoring
A fix was applied a little after 09AM UTC. We are monitoring the situation but so far it looks good.
Identified
We have identified an issue related to email processing modules in the UK south region and have a team working on restoring services.
Investigating
We are investigating an issue related to email processing module for customers in UK South region